View Issue Details

IDProjectCategoryView StatusLast Update
0000696UniTrackerMobile[Applications] developmentpublic2020-07-30 11:07
ReporterdomjosAssigned Todomjos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1.alpha.2 
Target Version1.1Fixed in Version1.1.alpha.3 
Summary0000696: Error on K3 2017 in Android 6.0
DescriptionFATAL EXCEPTION: Thread-2849
Process: de.domjos.unibuggermobile, PID: 29227
java.lang.RuntimeException: Unable to start activity ComponentInfo{de.domjos.unibuggermobile/de.domjos.unibuggermobile.activities.ExportActivity}: java.lang.NullPointerException: Attempt to invoke virtual method 'java.util.List de.domjos.unibuggermobile.helper.SQLiteGeneral.getAccounts(java.lang.String)' on a null object reference
    at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2440)
    at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2500)
    at android.app.ActivityThread.access$900(ActivityThread.java:163)
    at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1362)
    at android.os.Handler.dispatchMessage(Handler.java:102)
    at androidx.test.espresso.base.Interrogator.a(Interrogator.java:31)
    at androidx.test.espresso.base.UiControllerImpl.a(UiControllerImpl.java:131)
    at androidx.test.espresso.base.UiControllerImpl.a(UiControllerImpl.java:125)
    at androidx.test.espresso.base.UiControllerImpl.a(UiControllerImpl.java:40)
    at androidx.test.espresso.action.MotionEvents.a(MotionEvents.java:73)
    at androidx.test.espresso.action.Tap.b(Tap.java)
    at androidx.test.espresso.action.Tap$1.a(Tap.java:2)
    at androidx.test.espresso.action.GeneralClickAction.perform(GeneralClickAction.java:9)
    at androidx.test.espresso.ViewInteraction$SingleExecutionViewAction.perform(ViewInteraction.java:6)
    at androidx.test.espresso.ViewInteraction.a(ViewInteraction.java)
    at androidx.test.espresso.ViewInteraction$1.call(ViewInteraction.java)
    at java.util.concurrent.FutureTask.run(FutureTask.java:237)
    at android.os.Handler.handleCallback(Handler.java:739)
    at android.os.Handler.dispatchMessage(Handler.java:95)
    at android.os.Looper.loop(Looper.java:148)
    at android.app.ActivityThread.main(ActivityThread.java:5585)
    at java.lang.reflect.Method.invoke(Native Method)
    at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:730)
    at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:620)
Caused by: java.lang.NullPointerException: Attempt to invoke virtual method 'java.util.List de.domjos.unibuggermobile.helper.SQLiteGeneral.getAccounts(java.lang.String)' on a null object reference
    at de.domjos.unibuggermobile.activities.ExportActivity.loadData(ExportActivity.java:275)
    at de.domjos.unibuggermobile.activities.ExportActivity.initControls(ExportActivity.java:261)
    at de.domjos.customwidgets.model.AbstractActivity.onCreate(AbstractActivity.java:84)
    at android.app.Activity.performCreate(Activity.java:6279)
    at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1108)
    at androidx.test.runner.MonitoringInstrumentation.callActivityOnCreate(MonitoringInstrumentation.java:13)
    at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2393)
    ... 23 more
TagsNo tags attached.
GIT Revision3560314e648fd022235a35bf8757a3b2b8b9159a

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-07-30 09:32 domjos New Issue
2020-07-30 09:32 domjos Status new => assigned
2020-07-30 09:32 domjos Assigned To => domjos
2020-07-30 11:07 domjos Status assigned => resolved
2020-07-30 11:07 domjos Resolution open => fixed
2020-07-30 11:07 domjos Fixed in Version => 1.1.alpha.3
2020-07-30 11:07 domjos GIT Revision => 3560314e648fd022235a35bf8757a3b2b8b9159a