View Issue Details

IDProjectCategoryView StatusLast Update
0000695UniTrackerMobile[Applications] developmentpublic2020-07-30 10:53
ReporterdomjosAssigned Todomjos 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1.alpha.2 
Target Version1.1Fixed in Version 
Summary0000695: Error in pixel 3 android 9
DescriptionFATAL EXCEPTION: Thread-4
Process: de.domjos.unibuggermobile, PID: 19694
java.lang.RuntimeException: Unable to start activity ComponentInfo{de.domjos.unibuggermobile/de.domjos.unibuggermobile.activities.IssueActivity}: java.lang.NullPointerException: Attempt to invoke virtual method 'java.lang.Object de.domjos.unitrackerlibrary.model.issues.Issue.getId()' on a null object reference
    at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2951)
    at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:3086)
    at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:78)
    at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:108)
    at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:68)
    at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1816)
    at android.os.Handler.dispatchMessage(Handler.java:106)
    at androidx.test.espresso.base.Interrogator.a(Interrogator.java:31)
    at androidx.test.espresso.base.UiControllerImpl.a(UiControllerImpl.java:131)
    at androidx.test.espresso.base.UiControllerImpl.a(UiControllerImpl.java:125)
    at androidx.test.espresso.base.UiControllerImpl.a(UiControllerImpl.java:40)
    at androidx.test.espresso.action.MotionEvents.a(MotionEvents.java:73)
    at androidx.test.espresso.action.Tap.b(Unknown Source:16)
    at androidx.test.espresso.action.Tap$1.a(Tap.java:2)
    at androidx.test.espresso.action.GeneralClickAction.perform(GeneralClickAction.java:9)
    at androidx.test.espresso.ViewInteraction$SingleExecutionViewAction.perform(ViewInteraction.java:6)
    at androidx.test.espresso.ViewInteraction.a(Unknown Source:143)
    at androidx.test.espresso.ViewInteraction$1.call(Unknown Source:4)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at android.os.Handler.handleCallback(Handler.java:873)
    at android.os.Handler.dispatchMessage(Handler.java:99)
    at android.os.Looper.loop(Looper.java:193)
    at android.app.ActivityThread.main(ActivityThread.java:6718)
    at java.lang.reflect.Method.invoke(Native Method)
    at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:493)
    at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:858)
Caused by: java.lang.NullPointerException: Attempt to invoke virtual method 'java.lang.Object de.domjos.unitrackerlibrary.model.issues.Issue.getId()' on a null object reference
    at de.domjos.unibuggermobile.activities.IssueActivity.manageControls(IssueActivity.java:199)
    at de.domjos.customwidgets.model.AbstractActivity.onCreate(AbstractActivity.java:92)
    at android.app.Activity.performCreate(Activity.java:7144)
    at android.app.Activity.performCreate(Activity.java:7135)
    at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1271)
    at androidx.test.runner.MonitoringInstrumentation.callActivityOnCreate(MonitoringInstrumentation.java:13)
    at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2931)
    ... 25 more
TagsNo tags attached.
GIT Revision1501350885af66b9457486c857468f195cddd1ea

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-07-30 09:31 domjos New Issue
2020-07-30 09:31 domjos Status new => assigned
2020-07-30 09:31 domjos Assigned To => domjos
2020-07-30 10:53 domjos Status assigned => resolved
2020-07-30 10:53 domjos Resolution open => fixed
2020-07-30 10:53 domjos Fixed in Version => 1.1.alpha.3
2020-07-30 10:53 domjos GIT Revision => 1501350885af66b9457486c857468f195cddd1ea